[PATCH] [yaml2obj] ELF Relocations Support

Simon Atanasyan simon at atanasyan.com
Wed Apr 9 11:11:36 PDT 2014



================
Comment at: lib/Object/ELFYAML.cpp:579-580
@@ +578,4 @@
+    if (auto S = dyn_cast<ELFYAML::ContentSection>(Section.get())) {
+      IO.mapTag("!Section", true);
+      MappingTraits<ELFYAML::ContentSection>::mapping(IO, *S);
+    } else if (auto S = dyn_cast<ELFYAML::RelocationSection>(Section.get())) {
----------------
Sean Silva wrote:
> Now that I think about it, since in the future the ELFYAML::Section hierarchy is going to be growing, I think it would make sense to standardize on a consistent tag name scheme. It just bothers me that the generic "!Section" is being used for ContentSection, while "!Relocations" for RelocationSection. Can we standardize on having the tag be the name of the class?
Agreed. But I am not sure that ContentSection is a good name for tag. What do you think?


http://reviews.llvm.org/D3302






More information about the llvm-commits mailing list