[PATCH] Make StringMap aware of POD types

Benjamin Kramer benny.kra at gmail.com
Mon Mar 17 13:15:14 PDT 2014

On 17.03.2014, at 20:38, Chandler Carruth <chandlerc at google.com> wrote:

> On Mon, Mar 17, 2014 at 12:32 PM, Pete Cooper <peter_cooper at apple.com> wrote:
> I was worried about duplication, but actually that might be cleaner.  I’ll give that a try now.
> If the duplication is a problem, factor that into a private helper function used by both?

It can be written in two lines, not worth its own function.

for (auto &Entry : this)

- Ben

More information about the llvm-commits mailing list