[patch] Don't rename in Module::getOrInsertFunction.
rafael.espindola at gmail.com
Mon Mar 10 11:35:52 PDT 2014
Duncan recently reminded me that Module::getOrInsertFunction can
rename globals to make the new one fit. That is fairly surprising,
given the name of the function and what a central part of llvm it is.
Going over git log it looks like this was done to help with the
transition out of type planes. I have already done a simple "ninja
check-all" and both clang's and llvm's tests are clear. I will also
try a bootstrap and running the llvm testsuite.
Is the attached patch OK if all of the above works?
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 731 bytes
Desc: not available
More information about the llvm-commits