[PATCH] disabled switching ARM modes in inline asm
dpeixott at codeaurora.org
Wed Dec 11 14:56:15 PST 2013
A few questions/comments.
1. Would it be better to have convinence methods on the parser for querying
inlineasm state rather than exposing the enum directly? Something like
'isParsingInlineAsm()' vs. 'getInlineAsmKind() == MAK_RAW'? The named method
looks more readable to me.
2. You changed the name of 'isParsingInlineAsm()' to 'getInlineAsmKind()' in
the header, but I do not see any updates to call sites for that method. Is
it actually used anywhere? And if not do we still need the distinction
between the inline asm kinds.
> -----Original Message-----
> From: llvm-commits-bounces at cs.uiuc.edu [mailto:llvm-commits-
> bounces at cs.uiuc.edu] On Behalf Of Renato Golin
> Sent: Wednesday, December 11, 2013 1:15 PM
> To: grosbach at apple.com; amara.emerson at arm.com; garious at gmail.com
> Cc: llvm-commits at cs.uiuc.edu
> Subject: Re: [PATCH] disabled switching ARM modes in inline asm
> llvm-commits mailing list
> llvm-commits at cs.uiuc.edu
More information about the llvm-commits