[PATCH] Use the load-acquire/store-release instructions optimally in AArch32
resistor at mac.com
Thu Sep 19 15:43:48 PDT 2013
On Sep 19, 2013, at 2:53 AM, Artyom Skrobov <Artyom.Skrobov at arm.com> wrote:
> 1) whether all / some / none of the ATOMIC_xxx insts should explicitly have
> mayLoad = 1, mayStore = 1
I would generally err on the side of caution and go ahead and put them.
> 2) whether the change from getMemIntrinsicNode to getAtomic in
> ReplaceATOMIC_OP_64 (in Tim's words, "extending the semantics of a
> generic node") is a sensible approach.
I’m not very familiar with this area, but I’m OK with it in principle *if* you write some documentation into the ISDOpcodes list describing the new semantics and the operand layout.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-commits