[llvm] r187902 - Add the common begin/end naming convention to the coding standard.

Rafael Espindola rafael.espindola at gmail.com
Wed Aug 7 12:34:38 PDT 2013


Author: rafael
Date: Wed Aug  7 14:34:37 2013
New Revision: 187902

URL: http://llvm.org/viewvc/llvm-project?rev=187902&view=rev
Log:
Add the common begin/end naming convention to the coding standard.

Modified:
    llvm/trunk/docs/CodingStandards.rst

Modified: llvm/trunk/docs/CodingStandards.rst
URL: http://llvm.org/viewvc/llvm-project/llvm/trunk/docs/CodingStandards.rst?rev=187902&r1=187901&r2=187902&view=diff
==============================================================================
--- llvm/trunk/docs/CodingStandards.rst (original)
+++ llvm/trunk/docs/CodingStandards.rst Wed Aug  7 14:34:37 2013
@@ -796,7 +796,9 @@ In general, names should be in camel cas
   
 As an exception, classes that mimic STL classes can have member names in STL's
 style of lower-case words separated by underscores (e.g. ``begin()``,
-``push_back()``, and ``empty()``).
+``push_back()``, and ``empty()``). Classes that provide multiple
+iterators should add a singular prefix to ``begin()`` and ``end()``
+(e.g. ``global_begin()`` and ``use_begin()``).
 
 Here are some examples of good and bad names:
 





More information about the llvm-commits mailing list