[PATCH] [Object] Split the ELF interface into 3 parts.

Rafael Espíndola rafael.espindola at gmail.com
Wed Jul 31 14:35:19 PDT 2013


> Probably none, but I don't see why we should truncate unless there's a good reason. This class is going to be 16 bytes on a 64 bit system anyway.

ok

> ================
> Comment at: include/llvm/Object/ELF.h:365
> @@ -786,4 +364,3 @@
>
> -  Elf_Rel_Iter endELFRel(const Elf_Shdr *sec) const {
> -    return Elf_Rel_Iter(sec->sh_entsize, (const char *)
> -                        (base() + sec->sh_offset + sec->sh_size));
> +  Elf_Rel_Iter end_rel(const Elf_Shdr *sec) const {
> +    return Elf_Rel_Iter(sec->sh_entsize,
> ----------------
> Rafael Ávila de Espíndola wrote:
>> Having ELF in the name of this methods would be redundant, so I agree with dropping it, but why the switch away from CamelCase?
> Because all the other iterator functions are like this.

This is one part of the codebase that is fairly inconsistent. We have
alias_begin, beginSequence and begin_symbols. All of which don't
follow the style :-(. Using beginFoo and endFoo still look to be the
closest.

Would you be ok with beginRelocations? If so I can write a small patch
for the coding standard adding the exception about iterators.

> It's the size of the value in the file. I don't see a point in truncating.
ok

Cheers,
Rafael




More information about the llvm-commits mailing list