Fix for pr13145: Naming a function like a register name confuses the asm parser

Stepan Dyatkovskiy stpworld at narod.ru
Mon Mar 18 01:32:10 PDT 2013


Hello Chad.
Sorry about that, a little bit confused by ogre3d style. Variable name 
was fixed. I also replaced the comment.
Unittest is applied.
-Stepan.

Chad Rosier wrote:
> Hi Stepan,
> Here are a few nits:
>
> When writing comments, write them as English prose, which means they
> should use proper capitalization, punctuation, etc.
>
> +    // Want label whatever happened...
> +    bool wantLabelOnly = Mnemonic == "b" || Mnemonic == "bl";
>
> Maybe the comment could be something like, "If we've seen a branch
> mnemonic, the next operand must be a label."
>
> You could also rename wantLabelOnly to ExpectLabel or just put the
> conditional in the if statement; the comment should make clear the
> condition of the if statement.
>
> Most importantly, please add a test case before resubmitting to the list.
>
>   Chad

-------------- next part --------------
A non-text attachment was scrubbed...
Name: pr13145.patch
Type: text/x-diff
Size: 2208 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20130318/1447edc8/attachment.patch>


More information about the llvm-commits mailing list