[llvm-commits] [llvm] r170996 - /llvm/trunk/lib/Target/X86/X86FrameLowering.cpp

Sean Silva silvas at purdue.edu
Thu Dec 27 11:45:01 PST 2012


On Sun, Dec 23, 2012 at 12:30 AM, Nadav Rotem <nrotem at apple.com> wrote:
>        !MFI->hasVarSizedObjects() &&                     // No dynamic alloca.
>        !MFI->adjustsStack() &&                           // No calls.
>        !IsWin64 &&                                       // Win64 has no Red Zone
> -      !colobbersTheStack(MF) &&                         // Don't push and pop.
> +      !usesTheStack(MF) &&                              // Don't push and pop.
>        !MF.getTarget().Options.EnableSegmentedStacks) {  // Regular stack

Could you pull this huge `if` condition into its own static helper function?

-- Sean Silva



More information about the llvm-commits mailing list