[llvm-commits] [llvm] r166205 - /llvm/trunk/lib/Transforms/Vectorize/LoopVectorize.cpp

David Blaikie dblaikie at gmail.com
Thu Oct 18 13:22:20 PDT 2012


On Thu, Oct 18, 2012 at 1:17 PM, Tobias Grosser <tobias at grosser.es> wrote:
> On 10/18/2012 10:11 PM, David Blaikie wrote:
>>
>> On Thu, Oct 18, 2012 at 1:08 PM, Tobias Grosser <tobias at grosser.es> wrote:
>>>
>>> On 10/18/2012 08:34 PM, Nadav Rotem wrote:
>>>>
>>>>
>>>> Author: nadav
>>>> Date: Thu Oct 18 13:34:50 2012
>>>> New Revision: 166205
>>>>
>>>> URL: http://llvm.org/viewvc/llvm-project?rev=166205&view=rev
>>>> Log:
>>>> Avoid reconstructing the pointer set when searching for duplicated
>>>> read/write pointers.
>>>>
>>>>
>>>> Modified:
>>>>       llvm/trunk/lib/Transforms/Vectorize/LoopVectorize.cpp
>>>>
>>>> Modified: llvm/trunk/lib/Transforms/Vectorize/LoopVectorize.cpp
>>>> URL:
>>>>
>>>> http://llvm.org/viewvc/llvm-project/llvm/trunk/lib/Transforms/Vectorize/LoopVectorize.cpp?rev=166205&r1=166204&r2=166205&view=diff
>>>>
>>>>
>>>> ==============================================================================
>>>> --- llvm/trunk/lib/Transforms/Vectorize/LoopVectorize.cpp (original)
>>>> +++ llvm/trunk/lib/Transforms/Vectorize/LoopVectorize.cpp Thu Oct 18
>>>> 13:34:50 2012
>>>> @@ -166,7 +166,7 @@
>>>>
>>>>      // Check if a pointer value is known to be disjoint.
>>>>      // Example: Alloca, Global, NoAlias.
>>>> -  bool isKnownDisjoint(Value* Val);
>>>> +  bool isidentifiedSafeObject(Value* Val);
>>>
>>>
>>>
>>> Should this be 'isIdentifiedSafeObject()' ?
>>>                    ^ uppercase
>>
>>
>> "Function names should be verb phrases (as they represent actions),
>> and command-like function should be imperative. The name should be
>> camel case, and start with a lower case letter (e.g. openFile() or
>> isFoo())."
>>
>>   -
>> http://llvm.org/docs/CodingStandards.html#name-types-functions-variables-and-enumerators-properly
>>
>> It's inconsistent across the codebase because this particular standard
>> wasn't in place from the start. Generally the rule is to be consistent
>> with existing code (within a class, file, etc) but if you're making
>> large changes you can take the opportunity to clean things up.
>
>
> I am not sure what you want to say here. Do you agree or disagree with my
> remark?
>
> It is just a detail, but should the third letter not be uppercase due to the
> cameCase requirement in the coding standard?

Oh, sorry, - was a bit hard to read which identifier you were
referring to (my fault for not using a fixed width font in my mail
client).

Then yes, I agree with you.



More information about the llvm-commits mailing list