[llvm-commits] [cfe-commits] [PATCH] Add configuration of CLANG_VENDOR, VENDOR_GCC_VERSION

Ron Lieberman ronl at codeaurora.org
Wed Aug 29 15:19:00 PDT 2012


Sebastian and Rafael

The distinction is subtle, but we are ONLY controlling the GCC version as
output by the -dumpversion flag
The purpose of this configure option is to allow reconfiguration of what is
produced by -dumpversion without having to edit clang sources.
Thus reducing forward maintenance issues for us and others who might choose
to alter this version from its default.

Default build of clang produces 4.2.1

clang -dumpversion
4.2.1

A build configured to produce 6.0.00 for the Hexagon clang product produces
6.0.00

Hexagon-clang -dumpversion
6.0.00

The intent of the VENDOR_GCC_VERSION is simply to control what is printed by
the -dumpversion flag.
It does not changenor is it intended to change, the version number of the
product.

If at some point in the future, someone wishes to implement a configure to
set the product version, they might 
Indeed choose to use VENDOR_VERSION.

So given the above information, I would still suggest keeping it as
VENDOR_GCC_VERSION

(FYI: a more recent submission has the VERSION in the subject spelled
correctly,  I have altered this one to match)

Thanks,
Ron Lieberman
---
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum, hosted by
The Linux Foundation


-- ---Original Message-----
From: Sebastian Pop [mailto:spop at codeaurora.org] 
Sent: Wednesday, August 29, 2012 4:58 PM
To: Rafael EspĂ­ndola
Cc: ronl; llvm-commits at cs.uiuc.edu; cfe-commits at cs.uiuc.edu
Subject: Re: [cfe-commits] [PATCH] Add configuration of CLANG_VENDOR,
VENDOR_GCC_VERISON

On Wed, Aug 29, 2012 at 4:14 PM, Rafael EspĂ­ndola
<rafael.espindola at gmail.com> wrote:
> On 27 August 2012 14:41, ronl <ronl at codeaurora.org> wrote:
>> Our productizing of llvm+clang is named and branded as hexagon-clang.
>> We are producing a hexagon targeted compiler which does not rely on GNU
libc.
>> The product engineers did not want the output of -dumpversion to be 
>> 4.2.1 for our product, as this would imply some degree of compatibility
with GNU libc.
>> This change provides us with a mechanism to rebrand and 
>> change/enhance the product name, as well as emit a different sequence of
digits for  -dumpversion.
>
> So the intention is to not advertise it as gcc at all? In that can, 
> what about VENDOR_VERISON instead of VENDOR_GCC_VERISON?

s/VERISON/VERSION/g

I also find that VENDOR_VERSION is a better name.

Thanks,
Sebastian
--
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum, hosted by
The Linux Foundation





More information about the llvm-commits mailing list