[llvm-commits] [LLVM] [MC Disassembler] Addding support for dissassembler for MIPS

Medic, Vladimir vmedic at mips.com
Thu Mar 22 09:00:10 PDT 2012


He everyone,
please find attached the updated patch for MIPS Disassembler support, with fixes for the first two remarks received. As for the usage of isPseudo vs isCodeGenOnly, to the best of our knowledge the instructions with isPseudo attributes are skipped in code emitter modules (for example, MipsCodeEmitter::emitInstruction) so it's usage would break the functionality of other tools. We are looking forward to your further comments.
________________________________________
From: Rafael EspĂ­ndola [rafael.espindola at gmail.com]
Sent: Wednesday, March 21, 2012 4:57 PM
To: Medic, Vladimir
Cc: llvm-commits at cs.uiuc.edu; Jovanovic, Petar; Jim Grosbach
Subject: Re: [llvm-commits] [LLVM] [MC Disassembler] Addding support for dissassembler for MIPS

On 16 March 2012 11:45, Medic, Vladimir <vmedic at mips.com> wrote:
> Hi everyone,
> here is a patch that adds support for MIPS Disassembler. Comments are
> welcome.

First of all, thanks for doing this and for all the tests!

Nits:

> +
 > // Mips Pseudo Instructions Format

Do you want the extra line?


+  std::string TheTriple;

This can be a StringRef, no?

Given https://groups.google.com/group/llvm-dev/msg/d5c2be88fb5d0f1e ,
can you use isPseudo instead of isCodeGenOnly?

Cheers,
Rafael
-------------- next part --------------
A non-text attachment was scrubbed...
Name: MipsDisassembler.patch
Type: application/octet-stream
Size: 77148 bytes
Desc: MipsDisassembler.patch
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20120322/30a11dba/attachment.obj>


More information about the llvm-commits mailing list