[llvm-commits] [ASan] Intercept CreateThread on Windows (issue 5699064)

ramosian.glider at gmail.com ramosian.glider at gmail.com
Fri Feb 24 06:36:40 PST 2012


http://codereview.appspot.com/5699064/diff/4001/lib/asan/asan_internal.h
File lib/asan/asan_internal.h (right):

http://codereview.appspot.com/5699064/diff/4001/lib/asan/asan_internal.h#newcode263
lib/asan/asan_internal.h:263: # define THREADPROC
THREAD_CALLING_CONV or something more readable.

http://codereview.appspot.com/5699064/diff/4001/lib/asan/asan_internal.h#newcode281
lib/asan/asan_internal.h:281: typedef ThreadReturnType (THREADPROC
*ThreadProc)(void* param);
I think "thread_return_t" is more consistent with the rest of the code.

http://codereview.appspot.com/5699064/diff/4001/lib/asan/asan_thread.h
File lib/asan/asan_thread.h (right):

http://codereview.appspot.com/5699064/diff/4001/lib/asan/asan_thread.h#newcode68
lib/asan/asan_thread.h:68: static AsanThread *Create(int parent_tid,
ThreadProc start_routine,
thread_callback_t, worker_t?

http://codereview.appspot.com/5699064/diff/4001/lib/asan/interception/interception.h
File lib/asan/interception/interception.h (right):

http://codereview.appspot.com/5699064/diff/4001/lib/asan/interception/interception.h#newcode108
lib/asan/interception/interception.h:108: // without defining
INTERCEPTOR(..., foo, ...). For example, if you override
Please move this comment below or rewrite it.

http://codereview.appspot.com/5699064/diff/4001/lib/asan/interception/interception.h#newcode117
lib/asan/interception/interception.h:117: DEFINE_REAL_EX(ret_type, ,
func, __VA_ARGS__);
I think it's better to put something here as a missing argument.
(), maybe?

http://codereview.appspot.com/5699064/



More information about the llvm-commits mailing list