[llvm-commits] [ASan] Intercept functions on Windows - first version (issue 5690065)

timurrrr at google.com timurrrr at google.com
Wed Feb 22 06:01:40 PST 2012


On 2012/02/22 13:16:05, samsonov wrote:
> IMO InitializeAllInterceptors() really does look horrible now :)
It's less than 100LOC now

> I think we need to use functions like:
> InitializeSignalInterceptors()
> InitializePthreadInterceptors()
> InitializeGCDInterceptors()
> and so on. Probably these functions can be defined in their own .cc
file, but
> even now they may simplify things.
I agree, but not clear how to do this,
especially since we plan to introduce something like
asan_interceptors_{win,posix}.cc later.
Since these functions you suggest will be around 10-20LOC each I'd
rather wait a bit until it's clear how we do platform-specific
interceptors in the future.

> Also, what about using if (ASAN_WINDOWS)?
[per offline chat]
We'll need to compile non-Windows interceptors then, otherwise real_X
will not be defined.
I don't want to inject pthread_create just for a bit of extra code
readability :)

> > Thanks,
> > Timur

http://codereview.appspot.com/5690065/



More information about the llvm-commits mailing list