[llvm-commits] [llvm] r135418 - in /llvm/trunk: lib/Target/Mips/MipsISelLowering.cpp test/CodeGen/Mips/atomic.ll

Akira Hatanaka ahatanak at gmail.com
Mon Jul 18 14:00:26 PDT 2011


Okay, I think I can come up with better names.

On Mon, Jul 18, 2011 at 1:51 PM, Jakob Stoklund Olesen <stoklund at 2pi.dk>wrote:

>
> On Jul 18, 2011, at 1:31 PM, Akira Hatanaka wrote:
>
> Do you mean I should use vector or array instead? Or should I change the
> name "Tmp"? I understand "Tmp" is not very descriptive, but these registers
> are used as temporaries to store intermediate results.
>
>
> Don't use an array. I meant that you should use more descriptive names.
>
> I understand that these are in fact temporary variables, but Tmp1-Tmp13 is
> just too many. It must be possible to find better names.
>
> It is also confusing that Tmp5 is now missing.
>
> I am sorry to pin this on you. Maybe we should make Bruno fix it, if it is
> difficult? Or Sasa?
>
> Thanks,
> /jakob
>
>
>
> Thank you.
>
> On Mon, Jul 18, 2011 at 1:22 PM, Jakob Stoklund Olesen <stoklund at 2pi.dk>wrote:
>
>>
>> On Jul 18, 2011, at 12:58 PM, Akira Hatanaka wrote:
>>
>> > @@ -819,7 +819,6 @@
>> >   unsigned Tmp2 = RegInfo.createVirtualRegister(RC);
>> >   unsigned Tmp3 = RegInfo.createVirtualRegister(RC);
>> >   unsigned Tmp4 = RegInfo.createVirtualRegister(RC);
>> > -  unsigned Tmp5 = RegInfo.createVirtualRegister(RC);
>> >   unsigned Tmp6 = RegInfo.createVirtualRegister(RC);
>> >   unsigned Tmp7 = RegInfo.createVirtualRegister(RC);
>> >   unsigned Tmp8 = RegInfo.createVirtualRegister(RC);
>>
>> Interesting naming scheme. Please fix that. (I know you didn't do it.)
>>
>> http://llvm.org/docs/CodingStandards.html#ll_naming
>>
>> Thanks,
>> /jakob
>>
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20110718/3f6a5a15/attachment.html>


More information about the llvm-commits mailing list