[llvm-commits] [PATCH] Bug 5207: make APInt set(), clear() and flip() return void

Chris Lattner clattner at apple.com
Tue Nov 30 09:08:55 PST 2010


On Nov 30, 2010, at 7:14 AM, Jay Foad wrote:

> On 30 November 2010 09:04, Jay Foad <jay.foad at gmail.com> wrote:
>>> Looks great to me, please commit.  I'd also suggest renaming the methods to "setAllBits()" "clearAllBits" "flipAllBits" etc.  Thanks for working on this Jay!
> 
>> The methods are overloaded. We have:
>> 
>> void set(); // set all bits
>> void set(unsigned); // set a single bit
>> 
>> ... and likewise for clear() and flip(). So maybe rename them to
>> setAllBits() and setBit(unsigned) respectively?
> 
> Patch attached. It passes "make check". Do you like?

Looks great!



More information about the llvm-commits mailing list