[llvm-commits] [PATCH] Bug 5207: make APInt set(), clear() and flip() return void

Jay Foad jay.foad at gmail.com
Tue Nov 30 01:04:44 PST 2010


> Looks great to me, please commit.  I'd also suggest renaming the methods to "setAllBits()" "clearAllBits" "flipAllBits" etc.  Thanks for working on this Jay!

Committed.

The methods are overloaded. We have:

void set(); // set all bits
void set(unsigned); // set a single bit

... and likewise for clear() and flip(). So maybe rename them to
setAllBits() and setBit(unsigned) respectively?

Thanks,
Jay.




More information about the llvm-commits mailing list