[llvm-commits] [llvm] r80481 - /llvm/trunk/lib/Transforms/Scalar/InstructionCombining.cpp

Bill Wendling wendling at apple.com
Sun Aug 30 23:25:20 PDT 2009


On Aug 30, 2009, at 11:18 PM, Chris Lattner wrote:

> On Aug 30, 2009, at 11:15 PM, Bill Wendling wrote:
>
>>> +++ llvm/trunk/lib/Transforms/Scalar/InstructionCombining.cpp Sun  
>>> Aug 30 00:55:36 2009
>>> @@ -74,30 +74,27 @@
>>> STATISTIC(NumSunkInst , "Number of instructions sunk");
>>>
>>> namespace {
>>> -  class VISIBILITY_HIDDEN InstCombiner
>>> -    : public FunctionPass,
>>> -      public InstVisitor<InstCombiner, Instruction*> {
>>> -    // Worklist of all of the instructions that need to be  
>>> simplified.
>>> +  /// InstCombineWorklist - This is the worklist management logic  
>>> for
>>> +  /// InstCombine.
>>> +  class InstCombineWorklist {
>>
>> Would it make sense for this class to be marked 'VISIBILITY_HIDDEN'  
>> as well?
>
> VISIBILITY_HIDDEN is an optimization hint only useful for GCC  
> versions before 4.2.  I'm not too compelled to continue its use  
> anymore.  Would anyone object to ripping it out completely?
>
Ah! I see. I have no objection.

-bw




More information about the llvm-commits mailing list