[llvm-commits] [llvm] r74440 - in /llvm/trunk: include/llvm/MC/MCValue.h lib/MC/MCAsmStreamer.cpp

Chris Lattner clattner at apple.com
Tue Jun 30 23:27:59 PDT 2009


On Jun 29, 2009, at 12:51 PM, Daniel Dunbar wrote:
> Author: ddunbar
> Date: Mon Jun 29 14:51:00 2009
> New Revision: 74440
>
> URL: http://llvm.org/viewvc/llvm-project?rev=74440&view=rev
> Log:
> Rename MCValue::getCst to getConstant and add MCValue::isConstant.

Ok,

> +  int64_t getConstant() const { return Cst; }
>   MCSymbol *getSymA() const { return SymA; }
>   MCSymbol *getSymB() const { return SymB; }
> +
> +  bool isConstant() const { return !SymA && !SymB; }

Please rename isConstant() to isAbsolute() or something like that.   
Otherwise it sounds like isConstant() -> true is the only way the Cst  
field would make sense.  Do you agree?

-Chris



More information about the llvm-commits mailing list