[llvm-commits] [llvm] r63136 - /llvm/trunk/include/llvm/CodeGen/SelectionDAGNodes.h

Dale Johannesen dalej at apple.com
Tue Jan 27 14:26:00 PST 2009


On Jan 27, 2009, at 2:23 PMPST, Chris Lattner wrote:
> On Jan 27, 2009, at 1:41 PM, Dale Johannesen wrote:
>>
>> +  /// is that they will replace the above two over time, and
>> eventually
>> +  /// the ones above can be removed.
>> +  SDNode(unsigned Opc, SDVTList VTs, const SDValue *Ops, unsigned
>> NumOps,
>> +         DebugLoc sl)
>
> Do you think it would be reasonable to pass DebugLoc immediately after
> Opc?  Since all ctor/get methods will eventually convert to passing a
> location, it would be nice for them to be consistent.  If it is at the
> end of the list then we have get(opcode, ...random stuff depending on
> the accessor... , loc).  It would be nicer to have get(opcode,
> loc, ... random stuff depending on the accessor...)

OK, and now's the time to do it.  Should be a const argument too.





More information about the llvm-commits mailing list