[llvm-commits] [llvm] r42051 - in /llvm/trunk: lib/VMCore/Verifier.cpp test/CodeGen/Generic/GC/lower_gcroot.ll test/Verifier/gcread-ptrptr.ll test/Verifier/gcroot-alloca.ll test/Verifier/gcroot-meta.ll test/Verifier/gcroot-ptrptr.ll test/Verifier/gcwrite-ptrptr.ll

Duncan Sands baldrick at free.fr
Tue Sep 18 01:49:18 PDT 2007


Hi Gordon,

> +static bool HasPtrPtrType(Value *Val) {

I think hasPtrPtrType would be more in keeping with the LLVM naming rules
(whatever they are).

> +static Value *StripBitCasts(Value *Val) {

how about using IntrinsicInst::StripPointerCasts instead?

> +            "llvm.gcroot parameter #1 must be an alloca (or a bitcast).", &CI);

"(or a bitcast)" -> "(or a bitcast of one)"

> +            "llvm.gcroot parameter #2 must be a constant or global.", &CI);

how about dropping " or global" since it seems redundant.

Ciao,

Duncan.



More information about the llvm-commits mailing list