[llvm-commits] CVS: llvm/include/llvm/Constants.h

Reid Spencer rspencer at reidspencer.com
Thu Mar 29 21:25:07 PDT 2007


On Thu, 2007-03-29 at 21:02 -0700, Chris Lattner wrote:
> > +  /// This function will return true iff this constant represents  
> > a value with
> > +  /// active bits bigger than 64 bits or a value greater than the  
> > given uint64_t
> > +  /// value.
> > +  /// @returns true iff this constant is greater or equal to the  
> > given number.
> > +  /// @brief Determine if the value is greater or equal to the  
> > given number.
> > +  bool greaterOrEqual(uint64_t Num) {
> > +    return Val.getActiveBits() > 64 || Val.getZExtValue() > Num;
> 
> Shouldn't the second one be >= ?
> 
> Can you please rename this greaterOrEqualUnsigned  or even compare_gtu 
> (N)?

As this will get used in several places in InstCombine, how about just
uge ?

like the icmp predicate?

Reid.
> 
> 
> _______________________________________________
> llvm-commits mailing list
> llvm-commits at cs.uiuc.edu
> http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits




More information about the llvm-commits mailing list