[llvm-commits] CVS: llvm/lib/CodeGen/AsmPrinter.cpp IntrinsicLowering.cpp

Chris Lattner sabre at nondot.org
Sun Jan 14 18:28:15 PST 2007



Changes in directory llvm/lib/CodeGen:

AsmPrinter.cpp updated: 1.134 -> 1.135
IntrinsicLowering.cpp updated: 1.58 -> 1.59
---
Log message:

rename Type::isIntegral to Type::isInteger, eliminating the old Type::isInteger.
rename Type::getIntegralTypeMask to Type::getIntegerTypeMask.

This makes naming much more consistent.  For example, there are now no longer any
instances of IntegerType that are not considered isInteger! :)



---
Diffs of the changes:  (+3 -3)

 AsmPrinter.cpp        |    2 +-
 IntrinsicLowering.cpp |    4 ++--
 2 files changed, 3 insertions(+), 3 deletions(-)


Index: llvm/lib/CodeGen/AsmPrinter.cpp
diff -u llvm/lib/CodeGen/AsmPrinter.cpp:1.134 llvm/lib/CodeGen/AsmPrinter.cpp:1.135
--- llvm/lib/CodeGen/AsmPrinter.cpp:1.134	Fri Jan 12 12:15:09 2007
+++ llvm/lib/CodeGen/AsmPrinter.cpp	Sun Jan 14 20:27:26 2007
@@ -455,7 +455,7 @@
 
       // We can emit the pointer value into this slot if the slot is an
       // integer slot greater or equal to the size of the pointer.
-      if (Ty->isIntegral() &&
+      if (Ty->isInteger() &&
           TD->getTypeSize(Ty) >= TD->getTypeSize(Op->getType()))
         return EmitConstantValueOnly(Op);
       


Index: llvm/lib/CodeGen/IntrinsicLowering.cpp
diff -u llvm/lib/CodeGen/IntrinsicLowering.cpp:1.58 llvm/lib/CodeGen/IntrinsicLowering.cpp:1.59
--- llvm/lib/CodeGen/IntrinsicLowering.cpp:1.58	Sun Jan 14 20:03:16 2007
+++ llvm/lib/CodeGen/IntrinsicLowering.cpp	Sun Jan 14 20:27:26 2007
@@ -107,7 +107,7 @@
 /// LowerBSWAP - Emit the code to lower bswap of V before the specified
 /// instruction IP.
 static Value *LowerBSWAP(Value *V, Instruction *IP) {
-  assert(V->getType()->isIntegral() && "Can't bswap a non-integer type!");
+  assert(V->getType()->isInteger() && "Can't bswap a non-integer type!");
 
   unsigned BitSize = V->getType()->getPrimitiveSizeInBits();
   
@@ -193,7 +193,7 @@
 /// LowerCTPOP - Emit the code to lower ctpop of V before the specified
 /// instruction IP.
 static Value *LowerCTPOP(Value *V, Instruction *IP) {
-  assert(V->getType()->isIntegral() && "Can't ctpop a non-integer type!");
+  assert(V->getType()->isInteger() && "Can't ctpop a non-integer type!");
 
   static const uint64_t MaskValues[6] = {
     0x5555555555555555ULL, 0x3333333333333333ULL,






More information about the llvm-commits mailing list