[LLVMbugs] [Bug 19915] address sanitizer fails to pick up LD_LIBRARY_PATH

bugzilla-daemon at llvm.org bugzilla-daemon at llvm.org
Wed Jul 30 10:38:17 PDT 2014


Reid Kleckner <rnk at google.com> changed:

           What    |Removed                     |Added
             Status|REOPENED                    |RESOLVED
         Resolution|---                         |WORKSFORME

--- Comment #14 from Reid Kleckner <rnk at google.com> ---
(In reply to comment #13)
> I am seeing the same error with the official clang 3.4.2 binaries for ubuntu
> 14.04 from llvm.org. I am running the latest ubuntu 14.04 (which is 14.04.1
> now) with all packages up-to-date. I extracted the contents into /usr/local
> and "clang -v" bails out with the same error as Steven is having.

That's troublesome.  I think the micro releases of 3.4 started using C++11 to
make backporting easier.  I don't know what version of libstdc++ Ubuntu 13.10
has, but it appears that it isn't new enough.

There are two solutions for you: upgrade Ubuntu or build gcc 4.9, install it
locally, and point LD_LIBRARY_PATH at it's lib64 directory, as described in

I think your problem is different from Steven's problem, because he is already
setting LD_LIBRARY_PATH.  Your problem is expected fallout of using C++11 in
the 3.4 micro release branch, and it sounds like it's too late to fix.

Steven hasn't updated the bug in a month, and he hasn't provided the
information that Kostya asked, so I'm going to close this out.  Steven, feel
free to reopen if you have more information.

You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-bugs/attachments/20140730/737e522d/attachment.html>

More information about the llvm-bugs mailing list