[LLVMbugs] [Bug 16252] New: lli can't run GLES2 application

bugzilla-daemon at llvm.org bugzilla-daemon at llvm.org
Thu Jun 6 17:18:29 PDT 2013


            Bug ID: 16252
           Summary: lli can't run GLES2 application
           Product: tools
           Version: trunk
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P
         Component: lli
          Assignee: unassignedbugs at nondot.org
          Reporter: seongnam.oh at gmail.com
                CC: llvmbugs at cs.uiuc.edu
    Classification: Unclassified


I am trying to build an GLES2 application...just using text book sample.
after I created the LLVM bit code file....( the step was... )
1. compiling the files with clang with -emit-llvm -S option...
2. link the files with llvm-link
then, I got a bit code file.

what I tried to run the bit code file was like below : 

[root at ICEBREAKER llvm]# LD_PRELOAD="/usr/lib/libEGL.so /usr/lib/libGLESv2.so

[root at ICEBREAKER llvm]# lli CH02_HelloTriangle.bc
LLVM ERROR: Program used external function 'XOpenDisplay' which could not be

and I got the error message.

in order to make a native application, I used -lGLESv2 -lEGL -lm -lX11, then, i
tried to load the .so files...but still the lli is complaining that... and
dumping the libX11.so file which has the XOpenDisplay function.


You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-bugs/attachments/20130607/3b184a6f/attachment.html>

More information about the llvm-bugs mailing list