[LLVMbugs] [Bug 2976] New: Mips backend problem

bugzilla-daemon at cs.uiuc.edu bugzilla-daemon at cs.uiuc.edu
Wed Oct 29 04:51:27 PDT 2008


           Summary: Mips backend problem
           Product: new-bugs
           Version: unspecified
          Platform: Other
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: new bugs
        AssignedTo: unassignedbugs at nondot.org
        ReportedBy: ben.swire at tandberg.com
                CC: llvmbugs at cs.uiuc.edu

Created an attachment (id=2152)
 --> (http://llvm.org/bugs/attachment.cgi?id=2152)
disassembled bugpoint output

Using llvm 2.3, and llvm-gcc 4.2-2.3-x86-linux-RHEL4, I get a problem with the
Mips backend. I am basing my own backend on this one, so tried a test with it
first. A simple program outputs "Hello world", creates a variable and counts to

Running through instructions in example at the bottom of
http://www.llvm.org/docs/GettingStarted.html I run into trouble at step 6,
running llc with the argument -march=mips.

I have run bugpoint to reduce and llvm-dis on the output, and the problem seems
to be in returning an i32. (assuming I understand the system correctly!)

When running llc normally, I get the following error:

[bens at BenSCentOS llvm]$ llc hello.bc -f -o hello.s -march=mips
terminate called after throwing an instance of 'std::bad_alloc'
  what():  St9bad_alloc

Any ideas?

Configure bugmail: http://llvm.org/bugs/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

More information about the llvm-bugs mailing list