<div dir="ltr">I don't have a strong opinion, but I lean against the idea for two reasons:<div><br></div><div>1.  The `llvm::` prefixes don't really hinder readability for me.  They're like `std::` prefixes on all the C++ standard library types, which I'm perfectly happy to type and read--moreso than using declarations.  Sure, anybody who's been here a while knows which classes come from LLVM, but new folks might build that knowledge by seeing the prefixes.</div><div> <br></div><div>2.  I'm not a fan of forward declaring types provided by other parts of the code, as it requires intimate knowledge of implementation details.  In practice this may not matter much for the types we're considering.  If it grew more widespread, however, I'd be more concerned.  (Somewhere I've written a long explanation of this opinion.  I'll go search for it if anyone cares.  The Google style guide discourages forward declarations, but the rationale given there isn't as persuasive.)</div><div></div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Wed, Apr 17, 2019 at 4:18 PM Jonas Devlieghere via lldb-dev <<a href="mailto:lldb-dev@lists.llvm.org">lldb-dev@lists.llvm.org</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div dir="ltr"><div dir="ltr">Hey Pavel,<div><br></div><div>Sounds like a good idea. I don't have a strong opinion on this matter, but I'm always in favor of improving readability.</div><div><br></div><div>Cheers,</div><div>Jonas</div></div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Wed, Apr 17, 2019 at 3:38 AM Pavel Labath via lldb-dev <<a href="mailto:lldb-dev@lists.llvm.org" target="_blank">lldb-dev@lists.llvm.org</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Hello all,<br>
<br>
some llvm classes, are so well-known and widely used, that qualifying <br>
them with "llvm::" serves no useful purpose and only adds visual noise. <br>
I'm thinking here mainly of ADT classes like String/ArrayRef, <br>
Optional/Error, etc. I propose we stop explicitly qualifying these classes.<br>
<br>
We can implement this proposal the same way as clang solved the same <br>
problem, which is by creating a special LLVM.h <br>
<<a href="https://github.com/llvm-mirror/clang/blob/master/include/clang/Basic/LLVM.h" rel="noreferrer" target="_blank">https://github.com/llvm-mirror/clang/blob/master/include/clang/Basic/LLVM.h</a>> <br>
header in the Utility library. This header would adopt these classes <br>
into the lldb_private namespace via a series of forward and "using" <br>
declarations.<br>
<br>
I think clang's LLVM.h is contains a well-balanced collection of adopted <br>
classes, and it should cover the most widely-used classes in lldb too, <br>
so I propose we use that as a starting point.<br>
<br>
What do you think?<br>
<br>
regards,<br>
pavel<br>
<br>
PS: I'm not proposing any wholesale removal of "llvm::" qualifiers from <br>
these types, though I may do some smaller-scale removals if I'm about to <br>
substantially modify a file.<br>
_______________________________________________<br>
lldb-dev mailing list<br>
<a href="mailto:lldb-dev@lists.llvm.org" target="_blank">lldb-dev@lists.llvm.org</a><br>
<a href="https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-dev" rel="noreferrer" target="_blank">https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-dev</a><br>
</blockquote></div>
_______________________________________________<br>
lldb-dev mailing list<br>
<a href="mailto:lldb-dev@lists.llvm.org" target="_blank">lldb-dev@lists.llvm.org</a><br>
<a href="https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-dev" rel="noreferrer" target="_blank">https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-dev</a><br>
</blockquote></div>