<div dir="ltr">I have a patch locally that renames lldb_private::Error to lldb_private::LLDBError.  As you might expect, this is a pretty large patch so I don't plan to put it up for review, but since it's kind of a fundamental class I figured I should at least start a discussion.<div><br></div><div>The primary motivation for this is to enable cleaner interop between lldb's Error class and llvm::Error.  Currently there is an ambiguity between the two.  Obviously they are scoped in different namespaces, but it's still confusing when looking at code to see such similarly named classes.</div><div><br></div><div>There are a number of advantages to llvm::Error over lldb Error which I'm happy to elaborate on if anyone needs some clarification (I've also cc'ed lang on here, who wrote the original llvm Error implementation).</div><div><br></div><div>Long term I would eventually like to deprecate lldb's Error class entirely, and switch entirely to llvm::Error.  An intermediate transition phase would likely involve making something like LLDBWrapError which interoperates with llvm::Error and wraps an lldb_private::LLDBError.</div><div><br></div><div>For now though, I'm only proposing a very simple rename with minimal invasiveness.</div><div><br></div><div>Comments?</div></div>