[lldb-dev] RFC: Namespaces in lldb

Greg Clayton gclayton at apple.com
Mon Mar 23 11:05:18 PDT 2015


> On Mar 23, 2015, at 4:20 AM, Abid, Hafiz <Hafiz_Abid at mentor.com> wrote:
> 
> Jim,
> The initial developers of lldb-mi perhaps did not want to use the classes from
> lldb_private inside lldb-mi. So in some cases, they sort of duplicated the code
> for things like Mutex in lld-mi which are already available in host layer. If there
> are no objections on using lldb_private inside lldb-mi then I can remove that
> code duplication.

Please just switch to using C++11 for the host layer stuff (std::mutex, std::condition, etc). Don't expose or copy any code. Nothing from lldb_private should be used in any code that links against the LLDB shared library. If you want internal stuff, you should switch over to be a tool that links against the internal lldb_private stuff and not use the lldb::SB API. 

And I do prefer that we try and use the lldb::SB API for lldb-mi.

Greg





More information about the lldb-dev mailing list