[lldb-dev] [Bug 17501] New: There is no way to set argument like -Xxm100m

bugzilla-daemon at llvm.org bugzilla-daemon at llvm.org
Mon Oct 7 15:54:07 PDT 2013


            Bug ID: 17501
           Summary: There is no way to set argument like -Xxm100m
           Product: lldb
           Version: unspecified
          Hardware: PC
                OS: MacOS X
            Status: NEW
          Severity: release blocker
          Priority: P
         Component: All Bugs
          Assignee: lldb-dev at cs.uiuc.edu
          Reporter: yin at affinic.com
    Classification: Unclassified

On Oct 7, 2013, at 2:27 PM, Yin Ma <yin at affinic.com> wrote:


To set up a run argument, based on the document, it should be
Settings set target.run-args  , like gdb set args

However, no matter how, I cannot set my argument to –Xxm100M
I tried
Settings set target.run-args –Xxm100M
Lldb: invalid option – X

I also tried
Settings set target.run-args “-Xxm100M”
Doesn’t work.

Unfortunately you seem to be right. The only way I have been able to make this
work is by saying:
(lldb) sett set target.run-args -- --Xxm100M
(lldb) r
Process 5112 launched: '/private/tmp/args' (x86_64)
argv[0] = args
argv[1] = --
argv[2] = --Xxm100M

but as you can see, this causes a spurious - - (double dash) to be passed down
to your inferior process
Seems worth of a bugzilla to me. With that said, while I have not tried it, I
am kinda optimistic that SBLaunchInfo (the API class) would not be subject to
the same bug, since this is more of a command-line issue than anything

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/lldb-dev/attachments/20131007/235fc4b7/attachment.html>

More information about the lldb-dev mailing list