[lldb-dev] lldb problems on linux

Kaylor, Andrew andrew.kaylor at intel.com
Tue Aug 6 07:29:57 PDT 2013

Hmm...  I've never seen the -P option print the wrong path.  Looking at the code (in Host::GetLLDBPath) it doesn't even look possible for it to print what you're seeing.

On the other hand, the second directory you mention should be the correct one.  If you set PYTHONPATH to that does "python -c 'import lldb'" work?


From: Kal Conley [mailto:kcconley at gmail.com]
Sent: Tuesday, August 06, 2013 2:00 AM
To: Kaylor, Andrew
Cc: lldb-dev at cs.uiuc.edu
Subject: Re: [lldb-dev] lldb problems on linux

Hi Andy,
I tried
export PYTHONPATH=`$llvm/build/Debug+Asserts/bin/lldb -P`
but it didn't work for me. If I run `build/bin/lldb -P` it outputs "build/lib7/site-packages" which doesn't exist.
There is a directory build/lib/python-2.7/site-packages but if I set the PYTHONPATH to this directory I get the same errors.
I can import lldb; in python successfully though.
Any other ideas?

2013/8/5 Kaylor, Andrew <andrew.kaylor at intel.com<mailto:andrew.kaylor at intel.com>>
Hi Kal,

For the second problem, you need to set the PYTHONPATH environment variable.  Try this:

export PYTHONPATH=`$llvm/build/Debug+Asserts/bin/lldb -P`

Regarding the source information, I would start by using the following command within lldb (after you have created the target you want to debug):

target modules dump sections

If you don't see debug sections in that list, then that's the problem.  If you do, try enabling DWARF logging ('log enable dwarf all') and see if anything obvious turns up in the output when you try to set a breakpoint.


From: lldb-dev-bounces at cs.uiuc.edu<mailto:lldb-dev-bounces at cs.uiuc.edu> [mailto:lldb-dev-bounces at cs.uiuc.edu<mailto:lldb-dev-bounces at cs.uiuc.edu>] On Behalf Of Kal Conley
Sent: Sunday, August 04, 2013 11:27 AM
To: lldb-dev at cs.uiuc.edu<mailto:lldb-dev at cs.uiuc.edu>

Subject: [lldb-dev] lldb problems on linux

I recently build lldb from trunk (revision 187708) and source-level debugging isn't working for me. It seems its not loading any source information. What is the best way to troubleshoot this?
Also make check-lldb doesn't work on Linux when building with CMake. I just get error:

This script requires lldb.py to be in either /home/user/tools/llvm_3.4~svn187708/tools/lldb/build/Debug/LLDB.framework/Resources/Python, /home/user/tools/llvm_3.4~svn187708/tools/lldb/build/Release/LLDB.framework/Resources/Python, or /home/user/tools/llvm_3.4~svn187708/tools/lldb/build/BuildAndIntegration/LLDB.framework/Resources/Python
I get the same error with lldb-3.3.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/lldb-dev/attachments/20130806/dd926ea7/attachment.html>

More information about the lldb-dev mailing list