<div dir="ltr">Well, I agree in principle that the API is meant to support process launching.  But if its utility can be trivially extended to support other use cases, then why not?<br><div><br></div><div>FWIW, when I decided to do this, it was only to enable the functionality for other platforms (i.e. moving from specific dirs to common), because only Windows is going to have a different codepath here so it didn't make sense to increase the code debt for everyone just because of Windows.  Then changing of the signature was just something I noticed on the side.  I can change it back if people feel strongly, but at the same time, I really like making code as general as possible, as long as the generality doesn't hinder the readability or usability for the primary use case (which in this case I don't think it does)</div></div><br><div class="gmail_quote">On Wed, Feb 25, 2015 at 10:24 AM Enrico Granata <<a href="mailto:egranata@apple.com">egranata@apple.com</a>> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div style="word-wrap:break-word"><div>-    </div><div>-    void</div><div>-    SetShellExpandArguments (bool glob);</div><div>-    </div><div>+</div><div>+    void SetShellExpandArguments(bool expand);</div><div>+</div><div><br></div><div>Yes, totally</div></div><div style="word-wrap:break-word"><div><br></div><div><div>-    static Error</div><div>-    ShellExpandArguments (ProcessLaunchInfo &launch_info);</div><div>-    </div><div>+    static Error ShellExpandArguments(llvm::StringRef input, llvm::StringRef working_dir, std::vector<std::string> &expanded);</div><div>+</div></div><div><br></div></div><div style="word-wrap:break-word"><div>Why? I see no benefit to doing this. This API is clearly meant to support process launching. This change seems a net loss to me.</div><div><br></div><div>The actual moving of the argdumper logic to Host/common is fine (as long as the mechanism for individual platforms to opt out is trivial, that is) - the change in signature from ProcessLaunchInfo to bunch-of-stuff not so much</div><div><br></div><div><div>-    if (launch_info.GetFlags().Test(eLaunchFlagShellExpandArguments))</div></div><div><br></div><div>This should be fine do to do, yes</div><div><br></div><div><blockquote type="cite"></blockquote></div></div><div style="word-wrap:break-word"><div><blockquote type="cite"><div>On Feb 24, 2015, at 7:31 PM, Zachary Turner <<a href="mailto:zturner@google.com" target="_blank">zturner@google.com</a>> wrote:</div><br></blockquote></div></div><div style="word-wrap:break-word"><div><blockquote type="cite"><div>Anyone have thoughts on this?  If there's no suggestions I'd like to commit, but I'll give another day or two for comments.<br><br><br><a href="http://reviews.llvm.org/D7805" target="_blank">http://reviews.llvm.org/D7805</a><br><br>EMAIL PREFERENCES<br>  <a href="http://reviews.llvm.org/settings/panel/emailpreferences/" target="_blank">http://reviews.llvm.org/settings/panel/emailpreferences/</a><br><br><br><br></div></blockquote></div></div><div style="word-wrap:break-word"><div><blockquote type="cite"><div>_______________________________________________<br>lldb-commits mailing list<br><a href="mailto:lldb-commits@cs.uiuc.edu" target="_blank">lldb-commits@cs.uiuc.edu</a><br><a href="http://lists.cs.uiuc.edu/mailman/listinfo/lldb-commits" target="_blank">http://lists.cs.uiuc.edu/mailman/listinfo/lldb-commits</a><br></div></blockquote></div><br><div>
<div style="color:rgb(0,0,0);letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;word-wrap:break-word"><div style="color:rgb(0,0,0);letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;word-wrap:break-word"><div style="color:rgb(0,0,0);letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;word-wrap:break-word"><div style="color:rgb(0,0,0);letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;word-wrap:break-word"><div style="color:rgb(0,0,0);letter-spacing:normal;text-align:start;text-indent:0px;text-transform:none;white-space:normal;word-spacing:0px;word-wrap:break-word"><div>Thanks,</div><div><i>- Enrico</i><br>📩 egranata@<font color="#ff2600"></font>.com ☎️ 27683</div><div><br></div></div></div></div></div></div><br><br>
</div>
<br></div></blockquote></div>