[Lldb-commits] [PATCH] D147292: [lldb] Add support for the DW_AT_trampoline attribute with a boolean

Adrian Prantl via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Mon Apr 10 15:02:58 PDT 2023


aprantl added inline comments.


================
Comment at: lldb/include/lldb/Symbol/Function.h:439
   ///     The section offset based address for this function.
+  /// \param[in] generic_trampoline
+  ///     If this function is a generic trampoline. A generic trampoline 
----------------
Is the "generic" qualifier necessary here? If we later add support for trampolines with a jump target maybe, but without that this seems to just create opportunity for confusion, particularly for Swift where the word "generic" has very different connotations.


================
Comment at: lldb/source/Target/ThreadPlanStepThroughGenericTrampoline.cpp:2
+//===-- ThreadPlanStepThroughGenericTrampoline.cpp
+//-----------------------------------------===//
+//
----------------
formatting


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D147292/new/

https://reviews.llvm.org/D147292



More information about the lldb-commits mailing list