[Lldb-commits] [PATCH] D74556: [lldb] Don't call CopyForBreakpoint from a Breakpoint's constructor

Jonas Devlieghere via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Thu Feb 13 10:24:27 PST 2020


JDevlieghere accepted this revision.
JDevlieghere added a comment.

LGTM



================
Comment at: lldb/include/lldb/Breakpoint/Breakpoint.h:573
+  // target - primarily from the dummy target to prime new targets.
+  static lldb::BreakpointSP CopyFromBreakpoint(Target& new_target,
+      const Breakpoint &bp_to_copy_from);
----------------
nit: How about renaming this to `Breakpoint::CopyToTarget` instead? That seems a bit more explanatory than `Breakpoint:: CopyFromBreakpoint`. 


Repository:
  rLLDB LLDB

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D74556/new/

https://reviews.llvm.org/D74556





More information about the lldb-commits mailing list