[Lldb-commits] [PATCH] D66093: [Symbol] GetTypeBitAlign() should return None in case of failure.

Davide Italiano via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Mon Aug 12 11:20:11 PDT 2019


davide marked an inline comment as done.
davide added inline comments.


================
Comment at: lldb/source/Expression/Materializer.cpp:803
+
+      size_t byte_align = (*opt_bit_align + 7) / 8;
 
----------------
aprantl wrote:
> does this also need to be 7ull?
I'm going to move this to a function next to make sure we don't have to hardcode this everywhere.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D66093/new/

https://reviews.llvm.org/D66093





More information about the lldb-commits mailing list