[Lldb-commits] [PATCH] D42870: [lldb] [ObjectFile/ELF] Correct recognition of NetBSD images

Kamil Rytarowski via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Mon Feb 18 10:25:27 PST 2019


krytarowski added inline comments.


================
Comment at: source/Plugins/ObjectFile/ELF/ObjectFileELF.cpp:1359
+      //     p = patchlevel
+      const uint32_t version_major = version_info / 100000000;
+      const uint32_t version_minor = (version_info % 100000000) / 1000000;
----------------
mgorny wrote:
> Would it be crazy to rewrite this into `std::div` (i.e. to get both quotient and remainder in one call)?
If it will be more readable OK.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D42870/new/

https://reviews.llvm.org/D42870





More information about the lldb-commits mailing list