[Lldb-commits] [PATCH] D55757: ELF: Don't create sections for section header index 0

Greg Clayton via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Mon Dec 17 09:00:14 PST 2018


clayborg accepted this revision.
clayborg added a comment.
This revision is now accepted and ready to land.

Looks good. See inline comment and fix if you agree.



================
Comment at: source/Plugins/ObjectFile/ELF/ObjectFileELF.cpp:1993
     SymbolType symbol_type = eSymbolTypeInvalid;
     Elf64_Half section_idx = symbol.st_shndx;
 
----------------
Should we rename "section_idx" to "shndx" to make sure people know it is not a section index, but the ELF version of it?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D55757/new/

https://reviews.llvm.org/D55757





More information about the lldb-commits mailing list