[Lldb-commits] [PATCH] D55356: Add a method to get the "base" file address of an object file

Greg Clayton via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Thu Dec 6 12:09:24 PST 2018


clayborg requested changes to this revision.
clayborg added a comment.
This revision now requires changes to proceed.

This is already available with:

  virtual lldb_private::Address ObjectFile::GetHeaderAddress(); 

It return a lldb_private::Address which is section offset, but nothing stopping us from returning a lldb_private::Address with no section and just the file address. For mach-o the mach header is in the __TEXT segment, but not true for other file formats. I am ok if we need to rename "GetHeaderAddress()" to something else.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D55356/new/

https://reviews.llvm.org/D55356





More information about the lldb-commits mailing list