[Lldb-commits] [PATCH] D52788: Add EchoCommentCommands to CommandInterpreterRunOptions in addition to the existing EchoCommands and expose both as interpreter settings.

Stefan Gränitz via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Tue Oct 2 12:17:16 PDT 2018


sgraenitz marked an inline comment as done.
sgraenitz added inline comments.


================
Comment at: source/Interpreter/CommandInterpreter.cpp:2733
+
+  const char *k_space_characters = "\t\n\v\f\r ";
+  size_t first_non_space = line.find_first_not_of(k_space_characters);
----------------
shafik wrote:
> This looks like duplicate code from from `HandleCommand` I also see that at the the top of the file there is `k_white_space` although I am not sure why it is not in a anonymous namespace and why perhaps it is not a `ConstString`
Right, this is confusing. Any chance the extra escape sequences could make a difference in the context of line-wise command strings?
Anyway, yes I would feel better with one set of white space characters. Will check the details.
```
\f    Form Feed
\r    Carriage Return
\v    Vertical Tab
```


https://reviews.llvm.org/D52788





More information about the lldb-commits mailing list