[Lldb-commits] [PATCH] D50161: Add raw_ostream wrapper to the Stream class

Pavel Labath via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Thu Aug 2 02:50:43 PDT 2018


labath added a comment.

Wouldn't it be even better to actually expose the llvm class via some accessor or something? This way we could slowly migrate existing code by changing it to write to `stream.accessor()` instead of `stream` ? (I am not saying to do that now, but it opens up possibilities for the future.)

I also found it hard to deduce who is forwarding to whom from the member names. Maybe rename `m_forward_to` to `m_target` or something like that?


https://reviews.llvm.org/D50161





More information about the lldb-commits mailing list