[Lldb-commits] [PATCH] D43662: [Utility] Simplify and generalize the CleanUp helper, NFC

Adrian McCarthy via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Fri Feb 23 14:34:50 PST 2018

amccarth added a comment.

Nit:  As a single word, "cleanup" is a noun (or an adjective).  As two words, "clean up" is a verb.   Given that, I'd expect to see classes and objects with names like `Cleanup` or `cleanup` and functions to contain `CleanUp`.  When I see an identifier like `CleanUpTest`, I expect it's a function that cleans up after a test, not a test of a class called `CleanUp`.



More information about the lldb-commits mailing list