[Lldb-commits] [PATCH] D40537: Simplify UUID::IsValid()
Zachary Turner via lldb-commits
lldb-commits at lists.llvm.org
Tue Nov 28 10:28:39 PST 2017
On Tue, Nov 28, 2017 at 10:18 AM Stephane Sezer via Phabricator <
reviews at reviews.llvm.org> wrote:
> The other alternative seems a bit less explicit to me but I don't mind it
> too much. What's the issue with using `std::any_of` exactly?
In the sense of correctness, nothing is wrong with using std::any_of. But
if there's more than one way to do it, and one is easier to read /
understand, I just prefer it. I'm not blocking the CL or anything, it was
just a suggestion in the interest of readability.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the lldb-commits