[Lldb-commits] [PATCH] D29256: Do not pass non-POD type variables through variadic function

Ilia K via Phabricator via lldb-commits lldb-commits at lists.llvm.org
Tue Jan 31 23:13:56 PST 2017


ki.stfu added a comment.

In https://reviews.llvm.org/D29256#662167, @krytarowski wrote:

> @ki.stfu do you still agree with this patch?


Please follow my comments and then we can go ahead.



================
Comment at: tools/lldb-mi/MIDriver.cpp:512
         CMICmnThreadMgrStd::Instance().GetErrorDescription().c_str());
-    SetErrorDescriptionn(errMsg);
+    SetErrorDescriptionn(errMsg.c_str());
     return MIstatus::failure;
----------------
`SetErrorDescription` accepts a const reference to `CMIUtilString` so it suits better than `SetErrorDescriptionn` (double `n`).
```
SetErrorDescription(errMsg);
```

//Oh, certainly it should be renamed//


Repository:
  rL LLVM

https://reviews.llvm.org/D29256





More information about the lldb-commits mailing list