[Lldb-commits] [PATCH] D10906: Fix type signature for CMIUtilString::IsAllValidAlphaAndNumeric.This should take a "const char*" not a "char &".

Ilia K ki.stfu at gmail.com
Thu Jul 2 20:59:13 PDT 2015


ki.stfu requested changes to this revision.
ki.stfu added a comment.
This revision now requires changes to proceed.

Looks good apart from one renaming.


================
Comment at: tools/lldb-mi/MIUtilString.cpp:478
@@ -477,3 +477,3 @@
 // Type:    Static method.
 // Args:    vrText  - (R) The text data to examine.
 // Return:  bool - True = yes all alpha, false = one or more chars is non alpha.
----------------
ditto

================
Comment at: tools/lldb-mi/MIUtilString.cpp:483
@@ -482,3 +482,3 @@
 bool
-CMIUtilString::IsAllValidAlphaAndNumeric(const MIchar &vrText)
+CMIUtilString::IsAllValidAlphaAndNumeric(const MIchar *vrText)
 {
----------------
ditto

================
Comment at: tools/lldb-mi/MIUtilString.h:38
@@ -37,3 +37,3 @@
     static CMIUtilString FormatValist(const CMIUtilString &vrFormating, va_list vArgs);
-    static bool IsAllValidAlphaAndNumeric(const MIchar &vrText);
+    static bool IsAllValidAlphaAndNumeric(const MIchar *vrText);
     static bool Compare(const CMIUtilString &vrLhs, const CMIUtilString &vrRhs);
----------------
In vrText, "r"  means reference. Rename it to vpText.


http://reviews.llvm.org/D10906







More information about the lldb-commits mailing list