[Lldb-commits] [PATCH] Strip ELF symbol versions from symbol names

Zachary Turner zturner at google.com
Wed Feb 25 10:15:03 PST 2015


+majnemer.

I don't want to block this over a small change, but I really, really want to emphasize that I don't like seeing us performing string operations on mangled names.  It's already a big problem all over the codebase, and it's only getting worse.

If it's going to continue becoming increasingly common that we need to understand properties of mangled names, then please consider creating an abstraction in LLVM that has a nice interface and can query properties of mangled names like elf_name.GetNameWithoutVersion() or something similar.

+majnemer, who knows quite a bit about different naming schemes, and has already talked about writing such a class in LLVM.  So perhaps efforts to this effect could be coordinated.


http://reviews.llvm.org/D7884

EMAIL PREFERENCES
  http://reviews.llvm.org/settings/panel/emailpreferences/






More information about the lldb-commits mailing list