[Lldb-commits] [PATCH] Substitute 'cc' with 'c++' when compiling C++ test files.

Ed Maste emaste at freebsd.org
Mon Nov 10 13:20:10 PST 2014


================
Comment at: test/make/Makefile.rules:133
@@ -132,3 +132,3 @@
 # Function that returns the counterpart C++ compiler, given $(CC) as arg.
-cxx_compiler_notdir = $(if $(findstring clang,$(1)), $(subst clang,clang++,$(1)), $(if $(findstring icc,$(1)), $(subst icc,icpc,$(1)), $(if $(findstring llvm-gcc,$(1)), $(subst llvm-gcc,llvm-g++,$(1)), $(subst gcc,g++,$(1)))))
+cxx_compiler_notdir = $(if $(findstring clang,$(1)), $(subst clang,clang++,$(1)), $(if $(findstring icc,$(1)), $(subst icc,icpc,$(1)), $(if $(findstring llvm-gcc,$(1)), $(subst llvm-gcc,llvm-g++,$(1)), $(if $(findstring gcc,$(1)), $(subst gcc,g++,$(1)), $(subst cc,c++,$(1))))))
 cxx_compiler = $(if $(findstring /,$(1)),$(join $(dir $(1)), $(call cxx_compiler_notdir,$(notdir $(1)))),$(call cxx_compiler_notdir,$(1)))
----------------
It'd be nice if we can line wrap these (perhaps with a trailing `\`) to make it a bit more readable.

http://reviews.llvm.org/D6199






More information about the lldb-commits mailing list