[libcxx-commits] [PATCH] D88458: [CMake] Cache compiler-rt library results

Petr Hosek via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Tue Sep 29 16:35:03 PDT 2020


phosek added inline comments.


================
Comment at: compiler-rt/cmake/Modules/HandleCompilerRT.cmake:6
 #    COMPILER_RT_LIBRARY-<name>-<target> to NOTFOUND
-function(cache_compiler_rt_library err_flag name target library_file)
+macro(cache_compiler_rt_library err_flag name target library_file)
   if(err_flag OR NOT EXISTS "${library_file}")
----------------
compnerd wrote:
> Why change this to a macro?  Its setting a cached variable, which should be possible from within a function right?
This is an implementation detail which shouldn't be used from outside of this file, I was originally planning on moving it inside `find_compiler_rt_library` but then I realized we may also want to use it from `find_compiler_rt_dir`. Maybe we should rename this function to  `__cache_compiler_rt_library` to signal the fact that it's internal?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D88458/new/

https://reviews.llvm.org/D88458



More information about the libcxx-commits mailing list