[libcxx-commits] [PATCH] D86257: [libunwind] Split out UnwindInfoSections and dl_iterate_phdr lookup

Ryan Prichard via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Wed Aug 19 17:30:30 PDT 2020


rprichard created this revision.
rprichard added reviewers: saugustine, jgorbe, mstorsjo, compnerd.
Herald added subscribers: libcxx-commits, llvm-commits, krytarowski, mgorny.
Herald added projects: LLVM, libunwind.
Herald added a reviewer: libunwind.
rprichard requested review of this revision.

Move the dl_iterate_phdr-based unwind info lookup code into
FrameHeaderCache.hpp and rename it to DlIteratePhdrLookup.hpp.

Remove the unused dl_iterate_cb_data::addressSpace field.

Previously, FrameHeaderCache.hpp was included inside
"namespace libunwind { ... }", and the header recursively included
other headers. Now, DlIteratePhdrLookup.hpp is included in the global
namespace, following the ordinary convention. The lookup code uses the
UnwindInfoSections struct, so break the circular dependency by moving
the struct into its own file.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D86257

Files:
  libunwind/src/AddressSpace.hpp
  libunwind/src/CMakeLists.txt
  libunwind/src/DlIteratePhdrLookup.hpp
  libunwind/src/FrameHeaderCache.hpp
  libunwind/src/UnwindInfoSections.hpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D86257.286693.patch
Type: text/x-patch
Size: 28464 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/libcxx-commits/attachments/20200820/c272dc35/attachment-0001.bin>


More information about the libcxx-commits mailing list