[libcxx-commits] [PATCH] D86254: [libunwind] Minor fixes in libunwind

Ryan Prichard via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Wed Aug 19 17:10:43 PDT 2020


rprichard created this revision.
rprichard added reviewers: saugustine, jgorbe, mstorsjo.
Herald added subscribers: libcxx-commits, llvm-commits, kristof.beyls, mgorny.
Herald added projects: LLVM, libunwind.
Herald added a reviewer: libunwind.
rprichard requested review of this revision.

- When _LIBUNWIND_SUPPORT_COMPACT_UNWIND is defined in config.h, define it to "1" like the other macros. These macros are still checked using "#if defined(...)", however.
- Make findUnwindSectionsByPhdr static to avoid a potential ODR issue if the header is included in more than one TU.
- Include libunwind.h in AddressSpace.hpp before using _LIBUNWIND_ARM_EHABI.
- Rename ProcessFrameHeaderCache to TheFrameHeaderCache, because some configurations (e.g. Android / hermetic static libraries) can have one cache per shared object in the process. (When there are more copies, it's more important not to waste memory in the cache.)
- Add 3 missing header files to LIBUNWIND_HEADERS.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D86254

Files:
  libunwind/src/AddressSpace.hpp
  libunwind/src/CMakeLists.txt
  libunwind/src/config.h

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D86254.286689.patch
Type: text/x-patch
Size: 3558 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/libcxx-commits/attachments/20200820/ae46becf/attachment.bin>


More information about the libcxx-commits mailing list