[libcxx-commits] [PATCH] D77786: [AArch64] Add v8.5 Branch Target Identification support.

Daniel Kiss via Phabricator via libcxx-commits libcxx-commits at lists.llvm.org
Tue Apr 14 15:12:46 PDT 2020


danielkiss marked 4 inline comments as done.
danielkiss added a comment.

In D77786#1971668 <https://reviews.llvm.org/D77786#1971668>, @miyuki wrote:

> In D77786#1971519 <https://reviews.llvm.org/D77786#1971519>, @danielkiss wrote:
>
> > Please help me how to add a test for it, in the current state this patch won't do anything because the standard build for libunwind does not add -mbranch-protection=standard (or bti).
>
>
> I suggest adding a CMake variable to configure the branch protection option used when building the C++ libraries


Thanks, it will be a new patch.



================
Comment at: libunwind/src/assembly.h:47
+#elif (defined(__arm64__) || defined(__aarch64__)) && defined(__ARM_FEATURE_BTI_DEFAULT)
+#define PPC64_OPD1  \
+  .pushsection ".note.gnu.property", "a" SEPARATOR \
----------------
chill wrote:
> This will be emitted for all functions, but we need only one per object file, isn't it ?
> 
> Also, could you, please, rename `PPC64OPD{1,2}` to `TARGET_OPD{1,2}`, or `{ARCH ...}`, something like that.
> 
Yes, only one function per file today, but let's add the section per include. 

Rename is done.


================
Comment at: libunwind/src/assembly.h:48
+#define PPC64_OPD1  \
+  .pushsection ".note.gnu.property", "a" SEPARATOR \
+  .balign 8 SEPARATOR \
----------------
MaskRay wrote:
> I am worried that we may want to change the section type for .note.gnu.property 
> 
> https://sourceware.org/pipermail/binutils/2020-April/000372.html
Thanks for the heads-up, I'm not on that mailing list... 


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D77786/new/

https://reviews.llvm.org/D77786





More information about the libcxx-commits mailing list